NSS 5.0.0 =>10 to go!


#21

What does the turtle representation of your /public folder look like? Does it contain the weird URL? Try to create a folder with solid-ide. It might be a bug in solid-server or the data browser. If you can reproduce it persistently the way you described you should file an issue.


#22

solside shows

@prefix : <#>.
@prefix pub: <>.
@prefix ldp: <http://www.w3.org/ns/ldp#>.
@prefix terms: <http://purl.org/dc/terms/>.
@prefix XML: <http://www.w3.org/2001/XMLSchema#>.
@prefix sc: <https://roger.localhost:8443oger.localhost/public/scad/>.
@prefix st: <http://www.w3.org/ns/posix/stat#>.

pub:
    a ldp:BasicContainer, ldp:Container;
    terms:modified "2019-01-24T00:06:38Z"^^XML:dateTime;
    ldp:contains sc:;
    st:mtime 1548288398.392;
    st:size 4096.
sc:
    a ldp:BasicContainer, ldp:Container, ldp:Resource;
    terms:modified "2019-01-24T00:06:38Z"^^XML:dateTime;
    st:mtime 1548288398.428;
    st:size 4096.

jumbled @prefix sc: https://roger.localhost:8443oger.localhost/public/scad/.


#23

yeah, you should definetly file a bug


#24

Hi, got back to testing.

I tried it with a user name and sub folder name I never tried before. Same error.
Thanks for encouraging me to keep testing :slight_smile:

guess I’ll file an issue but as I read the Projects Panel I keep hoping the bug fixes they are working on lead to something usable; what I’m seeing/testing might not be relevant/useful as they are working on decentralization issues


#25

It’s a show stopper if you cannot create folders like this. I guess it will get fixed. Will try to reproduce it myself. Post the link to your issue here please


#26

#27

Hey, some NSS 5.0.0 commit in the last 3 weeks got my REST calls working again! Will test and report status of numerous types of calls…


#28

Ok, can now clone everything but the symlinks in a working copy in a pod from a git cloning. The binary and indexing of the pack seems to be working.

nss is linux file server based yet cannot provide the functionality of a sym link. Because of the current ldp limitations. (Can’t define a second container containing a folder).