Announcement: 5.0.0 Beta Series


#1

As the NSS-5.0.0 Project Release Manager, I’m happy to finally announce the Solid Server 5.0.0-beta.6 release!

The server is still a prototype, so it isn’t ready for sensitive data, but I’d like to draw your attention to it and ask if you can help test it.

Myself and the NSS-5.0.0 Project Contributors are looking to fix things that weren’t breaking in the 4.x series (i.e. regressions) before we release it, but it also contains so many important other fixes that more long-standing issues are something we would look at after the 5.0.0 release. Note, also, that some issues may be security fixes, it is possible though unlikely that apps have been relying on insecure behaviour, and so with tightened security, may break. If you find anything that used to work, that is now broken, please report it on github. If you report a regression the NSS-5.0.0 Project Contributors will try to address them before the final release of NSS-5.0.0.

You can get a full overview of the changes on the NSS - 5.0.0 project page.

You’ll find it on Github and NPM!

Kjetil (Project Release Manager)


#2

The beta is up on dev.inrupt.net, so you can test it there. It’s a developer testing environment so don’t be afraid to experiment.


#3

For those who prefer to read a digest of the most relevant changes, we have a hand-maintained changelog too.


#4

HI, I seemed to have messed up my new account on the dev inrupt, it sent me the welcome email, but I can’t reset my password - doesn’t seem to send the password reset email, can someone verify that?


#5

Just to make sure: You accessed https://dev.inrupt.net/account/delete and input your account handle?


#6

I entered in my account handle and clicked “send delete account link”, after a few mins i got…

image

any ideas?


#7

That was strange, @jucole. I tried to reproduce, but it worked for me. Perhaps there was simply some network problem somewhere, could you please try again?

Kjetil


#8

@kjetilk hi, no, same. i can see it tries to send a form post with my username, the page hangs and fails; no problem.


#9

Did you try clearing any SOLID relevant cookies? I have the same problem, but get past it by going to the /account/delete link, then deleting the /delete. Then I get an error page with a Login button, which then allows me to do so.

Well, tries to let me. I then get:

Error trying to parse <https://changeling.dev.inrupt.net/.acl> as text/turtle:
Line 7 of <https://changeling.dev.inrupt.net/.acl>: Bad syntax: Prefix foaf not bound.
at: "foaf:Agent;
    acl:accessTo <":
undefined

In any case, it would seem that, without any cookies set, the ERR_EMPTY_RESPONSE occurs. Once an interaction has occurred, the server sends a response.


#10

One side note:

If I have logged in, but encountered the parse error I mentioned above, i end up with this little gem :slight_smile: :

Note the Logout button vs the text of the message and error.


#11

I go to Web Developer Toggle Tools -> then t the Storage tab, expand Local Storage and right click delete all on the storage put there by soild-auth-client. Then refresh page and be back at the register/login view


#12

I got this one too until today’s commit 79c2741 9 hours ago. I’m testing by cloning and running local instances of nss


#13

I’m doing the same, but after Login, i simply get:

Error trying to parse &lt;https://justthisguy.dev.inrupt.net/.acl&gt; as text/turtle: Line 7 of &lt;https://changeling.dev.inrupt.net/.acl&gt;: Bad syntax: Prefix foaf not bound. at: "foaf:Agent; acl:accessTo &lt;": undefined```

Though I’m just using dev.inrupt.net, nothing local yet.


#15

Yea the solid-auth-client doesn’t seem to automatically get it’s state resync’ed with nss the way we(me) go thru webpages and tabs; I leave tabs up and come back to them all the time. Not sure http://dev.inrupt.net/ will be able to rapidly cycle thru tests and the updates nss will need to experience


#16

Oh, sorry about @changeling , you got bitten by a known bug. Fix was merged earlier today.


#17

Thanks, @kjetilk! Good to know. Is the fix live on the dev.inrupt.net yet, and are there actions I need to take?


#18

@changeling, no, I hadn’t anticipated it would actually bite someone that easily :blush: so I had planned to have the fix for https://github.com/solid/node-solid-server/issues/1068 in before making another beta release. Then @rubensworks or someone else at Inrupt will update the server. I think there is a good chance we’ll have the fix today, since @megoth has found the cause.


#19

I have uploaded solid-server@5.0.0-beta.7 to NPM now! You can upgrade if you have your own server, my fine Inrupt colleagues will upgrade dev.inrupt.net when they get to it.


#20

@rubensworks just told me he has upgraded dev.inrupt.net, so please have another round of tests!


#21

Cant seem to login to dev.inrupt.net; Even after a password change, still will not allow login.