Error: "Your profile ... is not editable"

Complete newbie here. I’ve just today created a pod on solidcommunity.net and have been playing around to see what I can do with it. So far I’ve created a private Address Book called ‘Family’ and added a couple of contacts. I then created another Address Book called ‘Contacts’ and (manually) copied the data from the first to a ‘Family’ group in the second. I then looked for a way to delete the old ‘Family’ Address Book and couldn’t find one.

The Data Browser User Guide says you can delete folder and data resources using the ‘Under the Hood’ view but I can’t see the cog icon anywhere. So I thought, perhaps, I needed to set my user type to ‘Power user’ and clicked on that. Nothing seems to have changed as a result but now, when I click on ‘Edit your profile’ I get this error message:

Your profile https://ploid.solidcommunity.net/profile/card is not editable, so we cannot do much here.

Can anyone tell me how to get out of this, please?

1 Like

Hi @ploid, we have observed a behaviour like that in the past, but I think it is still not clear what exactly causes it, see Profile/Preferences not editable even though logged in · Issue #29 · solid/solidos · GitHub

For now you can try to completely delete the browser cache for solidcommunity.net and ploid.solidcommunity.net, sometimes the session data is messed up and it appears that you are logged in though you are not. You can also try to log in using a fresh new private tab and see if it works there after you log in.

If you gain any insights please add a comment to the above issue

1 Like

Thanks, @aveltens, clearing the browser cache and logging in again has fixed the error.

2 Likes

I have seen this error with newly created Pods on NSS deployments. I assume it has something to do with the setting of the user type in their preferences as the error can be resolved by selecting a user type:

  1. Log into your Pod in Data Browser.
  2. Display Preferences (User menu → Preferences)
  3. If not selected, select the “Preferences” tab.
  4. Select the “Power User” and/or “Developer” user types.
  5. Refresh the browser.

If you select “Developer” as your user role, after the browser refresh you should be able to see the “Under the hood” icon.

Thanks @Kevin

I’m astounded that I need to use the “Developer” user type just to be able to delete things. As a newcomer to Solid I’ve been trying to keep things as simple as possible until I can find my way around. Setting the highest access level would have been the very last thing I would have tried without your comment. I’m finding it all a long way from intuitive, although I have now seen a description of the user types in the online User Manual. :confused:

I agree it is a little odd that you have to select “Developer” user type to allow Resources to be deleted in Data Browser. I think it was originally done to simplify the number of options displayed when a Resource is selected but may have gone a little far.

If you are investigating Solid, I would recommend checking out other applications for navigating a Pod:

Different takes on what is needed in a Pod navigator based on the user personas.