Problems adding Address Book and editing Profile


#1

Hey there, newbie here. I’m still trying to get used to Solid’s Panes and UI. And things seems to break by every click I make.

So far I created two webIds in inrupt and solid community just to check that the problems I am having were not provider specific.

https://glmaljkovich.inrupt.net/profile/card#me
https://glmaljkovich.solid.community/profile/card#me

Address Book


My steps were the following:

  • I went to my public folder
  • I pressed the + button to add a new App and selected Make new Address Book
  • I enter the name and I get a notice letting me now the Address Book has been created.
  • I click Go to new address book and I see this:

Ok, maybe try to add a new contact from the public folder?

When I do that I get different errors:

  • I click new contact, type the name and after it opens the new contact details, edit the name.
  • Editing the address

I tried creating a Group for the address book before adding a new contact but that didn’t fix the issue.

Profile


I went to https://glmaljkovich.inrupt.net/profile/card#me and tried to add an email address. And this showed up:

So I don’t know what I’m doing wrong. These are two new pods and I haven’t fiddled with any of the files.
I can open an issue on Github if that would be a better place.


#2

Generally the way you add contacts is by drag-and-drop, see: How to add a contact to your profile

Some browser/OS combinations seem to screw things up though.