Trying to set up a new pod - Fixed


#1

I’m trying to set up a new pod using the instructions on solid.inrupt.com , but I’m getting an error when I start the pod up:

solid:authentication Error registering a new client: { FetchError: request to https://meatpi.es/.well-known/openid-configuration failed, reason: connect ECONNREFUSED 167.99.34.28:443

Which is bit odd, as meatpi.es is the new server I’m setting up and it’s trying to connect to itself.

Any help would be appreciated

Keith


#2

Hmmmm, those kinds of errors can be hard to track down. The first think that comes to mind is that there is a firewall somewhere, that blocks the machine’s external interface from internal communication. I’ve been there, done that, spend hours on it without even getting a tee-shirt :wink:

If the request was completely internal, you would have seen it connecting on 127.0.0.1, so it is an internal request, trying to the external interface, then getting blocked.


#3

The firewall seems to be OK. Is it usual for the solid server to connect to itself at at startup?


#4

Where do you see that error message? Is it from the POD server log or is it from your browser when you try logging in?


#5

Solved it!

If anyone else sees the same issue, it’s a permissions issue on the https certificate - the solid user I set up didn’t have access (root only) so the server (silently) failed to start. Fixing the permissions solved the problem.

Thanks for the suggestions