Invalid Login to POD on own Server


#1

Hello to you all at SoLiD Project.
I have a problem, and hopefully someone is able to help me out…
I set up a solid server on a Debian 9 server.
Finally it worked out and I got my WebID.
I registered and created an account.
But I cant really login. It says:
“Invalid login! Did you set https://solid.community as your OIDC Provider in your profile#me”
Tried some research, the only thing I found was:
solid:oidcIssuer to add to my card#me, but that had no effect.
I found nothing about oidc Provider related to SoLiD…
Could someone direct me to a possible solution?
Has someone similar errors?
Maybe I messed something up in the setup process…?
Thanks in advance, Joachim :smiley:


#2

Hello, again, I can sort of login… but I can not access private inbox folder.
Error msg:
Outline.expand: Unable to fetch and Failed to load mypod.de:8443/inbox/ Fetcher: mypod.de:8443/inbox/ Invalid login status: 401

Has somebody any thoughts about that?

thanks, Joachim :smiley:


#3

It could be related to https://github.com/solid/solid/issues/165 ? It’s an issue on the community servers, and I’m struggling a bit to replicate on my local setup.

Maybe you could confirm whether or not you think it’s the same issue? I’ll look at your feedback above as part of working on that issue, might give me some hints.


#4

Thanks @megoth for answering!
Yes it should be the same issue that pcav stated.
I’m poking around in the oidc folder, but had no luck yet.
I set the oidcIssuer to my pod address and I could login, but
if I wanted to change somethin in the inbox folder, I had to login again
and there was the issue again.
If I’ll find something, I’ll post it!
Thanks again, you’re working on a great project! :smiley:
Jo


#5

If I’ll find something, I’ll post it!

Please do! I’m having problems reproducing this bug =/

Thanks again, you’re working on a great project! :smiley:

I know, I’m loving this! :slight_smile:


#6

Hello @megoth, are you over this bug?
Sry, I was not into pod subject for quite a long time.
Would it help, if we would setup my pod from the ground up?
Maybe you join via team viewer or something like that, then
you could see what goes wrong…
My setting is windows 10 , server on german co called strato.
Debian 8 server, manually updated to stretch.

Regards, jo