Problems updating node-solid-server


#1

Hi all,
First time post, so apologies if this has a well known solution, or is in the wrong place.

I’m running a multi-user test solid pod server hosted on a subdomain.

The initial installation installed node-solid-server version 5.1.1. I’m running it behind nginx, and followed the instructions on https://solid.inrupt.com/docs/installing-running-nss (with the exception of the directory - I’m just running the server from a directory located in a home directory, not /var/www/). This worked fine.

I attempted to update the solid server, by running sudo npm update -g solid-server.

Now, whenever I try and log in to a pod on the server, I get an Unauthorized message in a blank window after entering the identity provider URL in the popup window (it doesn’t get as far as asking for my password). The symptoms are roughly https://github.com/solid/node-solid-server/issues/865

Clearing all site data for my domain seems to occasionally fix the problem, but if I log out and in again then I’m usually faced with the same issue. I’ve tried downgrading the solid server to 5.1.1 and 5.1.2, and wiping the pod data (and then rerunning solid init in a clear directory).

I would have expected wiping the site data to work… Any ideas?