Login in a local Solid Sever using the 'solid-node-client'

Hi everyone,

I’m creating a script to login into my pod stored on a local server. I’m using the ‘solid-node-client’, but I’m getting in trouble.
First, I ran a local server of CommunitySolidServer, then I created some Pods there.
Second, I ran the example in solid-node-client and I got that error at the server console when I access my POD http://localhost:3000/GG, I get this at the server console:

2022-11-15T13:54:56.705Z [BaseHttpServerFactory] {Primary} info: Received POST request for /GG/login/password
2022-11-15T13:54:56.756Z [WebAclReader] {Primary} info: Found applicable ACL document http://localhost:3000/GG/.acl
2022-11-15T13:54:56.776Z [PermissionBasedAuthorizer] {Primary} warn: Unauthenticated agent has no append permissions

It’s important to note that I executed the same script in an online server (https://solidcommunity.net) and succeeded.

Is there a specific configuration to do on the server? I have added the https://solid-node-client as a trusted app on the root Pod.

Can anyone point me in the right direction?

Thank you.

As described in the README for solid-node-client (disclaimer, I am its author), the login using username and password is only one option offered by the library and only works on NSS (Node Solid Server), You have apparently installed CSS ( Community Solid Server), which does not support username/password login.

Take a look at this document to see what CSS expects for login : Client credentials - Community Solid Server

[EDIT : found a good link to refer to]

Hello @jeffz,

Thank you for your answer. In fact, I’m using the CSS.
I think this document can be useful for me. Now, I’ve been working in a scenario with devices collecting and saving personal data in Pods. I need to authorize these devices to read/write/append data in Pods. It will be a continuous process until the data owner explicitly cancels this authorization.