Solid Plume - simple blog app


This was fixed a few days ago, here’s the related issue:

This isn’t the error cause for the solid-filemanager though. I guess the cause here is, that it sends content-type: undefined while it (probably) should guess and specify it. I’d refactor it sometime after the solid-file-client update. If you want it to be changed earlier, PRs (which don’t break other stuff obviously) are accepted.


Did you used @A_A solid-file-manager? Which version of @happybeing Plume did you used? I’ve tried to deploy on my POD using @A_A solid file manager and latest Plume release v0.11 and once deployed following instructions I got a download instead of a ‘live deployment’ of Blog.

Not sure if the issue can be related to solid-file-manager extracting .zip files or NSS side… :thinking:

Happy to test any other combination :slight_smile:


First Time, I used the same instructions as you and had same problem.
But another of install can be used as mentioned here Solid Plume - simple blog app


Thank you! I had already tried that method too but I was receving some HTTP 403 Errors…
I have just realized that I would need to setup permissions of the Solid Copy App from @A_A in my POD and tried again… This time has worked! Finally Deployed!

Then I guess it’s clear that something wrong is going (bug?) with the actual version of solid file manager (react based app)

Thank you so much! :slight_smile:


Yes, as mentioned above solid-filemanager uses content-type: undefined which likely causes the download instead of rendering it in the browser. It will be fixed in the future, but I will wait until the new solid-file-client library is released and until I have enough free time. Likely before the end of this year, but I can’t promise it.

The installing via Solid Copy (see above) works without errors afaik.


@A_A, trying

  • it would be cool if you could add a logout item in the menu of Solid-File-Manager, so we could switch from a pod to another.


@Smag0 Click on the three dots in the top right corner -> Choose Root Location -> Logout :slight_smile:
(If you have further questions or remarks to solid-filemanager, I’d suggest to do them in the solid-filemanager thread or in a github issue)


Using @A_A 's Solid Copy app, I’m also coping with either a never-ending “copy” with no results or a 403 error (“403 Origin Unauthorized https://mypod…/public/”).
@alexcorvis84, what do you mean with

I’ve tried with all “access modes” activated for, but nothing helps…


If i remember well, I setup the Solid Copy App trusted application like below and it worked for me…

The I followed the installation steps detailed by @A_A without errors and deployed Plume Blog on my own Pod.


Also, there’s an updated version of solid-copy on github:
I’d suggest to use this one. It also tells you how to add it to the trusted apps on the left side of the screen.