POD CHAT Messenger For Solid POD´s (..that works!)

Hello forum

has anyone here tried the Solid POD messenger at https://pod-chat.com and what is your opinion about it? There is still some bug in google chrome. So try to use another browser. And also you have to grant all 4 permissions when you login for the first time!

If you want to try it out before inviting all your friends you can add “Pod-Chat” (https://pod-chat.solidcommunity.net/profile/card#me) to your contacts and write us a message…:wink:


Tried it just now, is it yours? Appears to work pretty well :slight_smile: If anyone wants to send me a message, use the WebID https://vincent-test.inrupt.net/profile/card#me

Out of interest, is the source code available somewhere? If not, care to share what tools were used when building it?

1 Like

…i just wrote you (https://Pod-Chat.solidcommunity.net/profile/card#me). i am just the wordpress developer so i dont know the details of the programming. but it will be shared once its 100% bug-free. if anyone wants to try it just add my POD to your contacts and write me… :blush:

1 Like

Hmm, I don’t see your message unfortunately, but I did just now start a new chat with you, so hopefully you’ll be able to see that :slight_smile:

1 Like

…did you when you logged in for the first time grant all 4 authorizations? if you have only granted 3 the messenger wont work… try to register a new pod and remember when you login for the first time to grant ALL 4 rights to the messenger…

Hmm, for me it always gets a 401 when retrieving inbox and privateTypeIndex, although I am logged in and gave all permissions :confused:

1 Like

Yep, did that!

                n1:mode n1:Append, n1:Control, n1:Read, n1:Write;
                n1:origin <https://pod-chat.com>
1 Like

did you register a new pod and logged in again? what your new pod?

…there is some sort of bug in the chrome browser. so maybe try another browser…

I’m usually using Firefox. Tried it in Chromium too just now, but then my own chats aren’t even listed.

I was using my existing Pod. I just created a new account https://podchattest.solidcommunity.net/profile/card#me. Sent a message to you, and to myself, but I don’t see it in my own Pod either.

1 Like


1 Like

Works for me now using firefox and my existing WebID

1 Like

@root66 I got notifications about your messages, but they don’t show up on pod-chat.com :disappointed:

@aveltens i have just written to you from firefox. but i guess that wont change anything. i guess it´s something to do with you having your own server. i will forward your situation to the developer and see what he thinks. thanks for your reply and patience… :wink:

…it seems unfortunately that so far pod-chat only works between pods from the same provider :roll_eyes:

I’ ve tried with testpro.solidweb.org and ewingson.solidcommunity.net in both directions and it didn’ t work out. the add friend functionality was okay in both directions but I didn’ t manage to start a chat. I’ ll append a screenshot of the dev console. it says cannot process inbox notifications.podchaterror

I’ ve granted read, write, append and control permissions.

[edit 2021-03-08 19:54 GMT+01] seemed to be a browser problem. chromium didn’ t do it, but firefox did. works

1 Like

…i just send you a message to your solidcommunity pod. hope it reaches you :wink:

to make sure this app works in Google Chrome you have to disable the “same cookie enforcement” by simply entering: chrome://flags/#same-site-by-default-cookies Into your browser address-bar, hit enter, disable the cookie enforcement and relaunch the browser