NSS with login free mode


#1

Hi,

So that applying developers don’t need to wait till security, certificates and authentication are working it would be nice if there was a mode that skipped all that and allowed us to develop and test the rest of node-solid-server.


Local setup Solid-Server gets bugs
#2

This really is essential if you want an ecosystem of applying developers to begin to grow. Let us work!


#3

I think that’s exactly what the forceUser config parameter is for!


#4
--force-user [value]          Force a WebID to always be logged in (useful when offline)

I’ll give it a try but that’s not what it’s description says


#5

causes in the nss server side log:

(node:14007) UnhandledPromiseRejectionWarning: Error: NamedNode IRI "roger" must be absolute.

this a a fresh clone with no users yet; maybe I need to add the --force-user on a restart after I register user for the first time…


#6

Ah, ok, I think I misunderstood the question. You’d like to test the REST API aspect of a Solid server without dealing with permissions or authentication?

There is a config flag for that, too, webid: false.


#7
bin/solid-test start --help

--webid                       Enable WebID authentication and access control (uses HTTPS)

there is no arg for it. When I put false after --webid it spits out usage and stops

I’m running fresh clone of https://github.com/solid/node-solid-server/tree/release/v5.0.0


#8

I do think there is a bug causing a lot of havoc with logging in or making rest calls:

when I don’t do this browser refresh of public page but go to my test app(one that worked a bit with nss v4) I still get user unauthorized on rest calls


#9

Yeah, I’m not sure what’s up with the command line arg for --webid. But you can edit your config.json file manually, and add "webid": false to it


#10


I don’t think turning off webid gets very far


#11

Why, what happens?


#12
Error trying to parse <https://roger.localhost:8443/.acl> as text/turtle:
Line 7 of <https://roger.localhost:8443/.acl>: Bad syntax: Prefix foaf not bound.
at: "foaf:Agent;
    acl:accessTo <":
undefined

as the Prerequisites on https://github.com/solid/node-solid-server/tree/release/v5.0.0#pre-requisites say “While these steps are technically optional (since you could launch it in HTTP/LDP-only mode), you will not be able to use any actual Solid features without them.”


#13

Ahh ok. That might be a bug. Using solid-server without auth is not an area that gets a lot of user testing.

So, I suspect it’s not really possible to set up a server without creating (self-signed or otherwise) SSL certificates, by just initializing it with webid: false. I’ve seen webid: false run for testing purposes /after/ a server is set up. But I don’t think anybody’s done what you’re trying to do.