Disable security certificate with @solid/cli


#1

Hi everyone,

I managed to configure a Solid server on a Raspberrypi (I used a self signed certificate) and it worked well with a classic web browser.

Now I try to make request throw a nodejs server, with @solid/cli.
In a first time I try to make a login request but I met an error during the request.

E_LOGIN request https://unpost.pi:8443/ .well-known/openid-configuration failed, reason: self signed certificate

I understand this error is because of the self signed certificate, and I know it’s possible to disable the security check. But I don’t manage how to do this.

Do you have any idea to skip this security check ?


#2

How are you launching the nss?

export DEBUG=solid:*
bin/solid-test start --webid --auth oidc --multiuser --port 8443 --ssl-cert /home/roger/NodeProjects/roger-g74s.cert --ssl-key /home/roger/NodeProjects/roger-g74s.key --root ./data 


#3

I’m launching the node solid server with a solid.service file wich contains this line :

ExecStart : /usr/bin/solid start --server-uri https://unpost.pi:8443 --config-file ./config.json --no-reject-unauthorized.

I enable the multiuser mod with a solid init and the certificates location are given during this init too.


#4

Oh I wasn’t referring to switches vs init; the launcher
bin/solid-test sets
export NODE_TLS_REJECT_UNAUTHORIZED=0
and turns on the switch
–no-reject-unauthorized


#5

Hi, thank you for your help.

So I did that :

pi@pi:/usr/lib/node_modules/solid-server $ bin/solid-test sets export NODE_TLS_REJECT_UNAUTHORIZED=0
pi@pi:/usr/lib/node_modules/solid-server $

Nothing special happen. After I tried to start my server in two different way :
First one with solid-test :

pi@pi:/usr/lib/node_modules/solid-server $ sudo bin/solid-test start --webid --auth oidc --multiuser --port 8443 --ssl-cert /home/solidkeys/fullchain.pem --ssl-key /home/solidkeys/privkey.pem --root /home/solid_server/data --no-reject-unauthorized --server-uri https://unpost.pi:8443
TIP create a config.json: $ solid init
Solid server () running on https://localhost:8443/
Press +c to stop

But I still have the error :

pi@pi:~/NodeServer $ ./client.py $LOGIN_Q
Bytes Sent: {“query”:“login”,“content”:{“idp”:“https://unpost.pi:8443/login",“username”:“Alice”,“password”:"AlicePOD”}}
Bytes Received: {“status”:“E_LOGIN”,“text”:“request to https://unpost.pi:8443/.well-known/openid-configuration failed, reason: self signed certificate”}

And I tried to start my server like I said before and I have the same error.
Maybe I misunderstand something sorry …

I have tried to search and I think the issue comes from the client as my server never received the request. I found that the error comes from the code in /usr/lib/node_modules/@solid/cli/src/SolidClient.js

Exactly it’s this call in the code:
24 // Obtain a relying party
25 const relyingParty = await this.getRelyingParty(identityProvider);

Thank you again for your help.