I can't create a folder in /public folder


#1

Hello, I’m doing a solid chat and I have a problem creating a folder and in the response preview I receive " No permission to access this resource
You are currently logged in as https://myaccount.solid.community/profile/card#me , but do not have permission to access https://myaccount.solid.community/public/ "
If I try to create the folder in inbox how I have the submitters permission for everyone I haven’t any problem to create it, in public folder Everyone have permission only to read.
I use solid-file-client and solid-auth-client and I don’t know how I can solve this.
Thanks for helping me.


#2

Sometimes multiple logins can cause this. Make sure you are not logged in to the pod in another window, then, in your script, logout before you login .


#3

Yes, i have an alert about that,(Caution: multiple versions of solid-auth-client active.) what do you think causes this? I am sure about that i’m not logged in another tab or window and I already try to logout too. Thank you very much.


#4

Try it from incognito mode.


#5

I tried it and the same result


#6

Have you tried to create the folder directly via the Data Browser? ( https://myaccount.solid.community/public/)
If it works, you can compare the requests you made and the ones from the databrowser.