Access Private SOLID-Pod by third part


#1

Dear Community,

since I have not seen any similar question, I post this one as a new topic:

I need a demo where I can demonstrate that in a private SOLID Pod only authorized customers can access private folders:

• Lighorne defines a private folder https://lighorne.inrupt.net/private/ and there he defines the access rights (according to these instructions https://github.com/solid/userguide/blob/master/views/sharing/userguide.md). This folder is private, but Lighorne grants access to Huffam to this folder
• Huffam gets a link from Lighorne. However, Huffam cannot access this folder, despite Lighorne provided him rights to access.
• Wow can Huffam access private information stored in SOLID? How are these access rights defined?

Furthermore: is possible to store a picture in a folder? (I can only upload text files)


#2

Does Huffman login with it’s webId ?
To post a picture you can use some tools like


#3

Thank you. Yes, Huffam is loging with his webID.
I have supposed that with Solid:

Regarding your interface: yes, I have discovered it today and looks very good. I need some time to continue testing it, as well as test your code.


#4

did you try “Huffman login to lighorne pod ?” as the data is stored on lighorne pod


#5

It works now. Thank you very much.
Before I made a systematical error: first login as huffam, then open leighorne’s SOLID-Pod and then try to access the folders.

The correct sequence is:

  1. Open the link in the browser that you want to access, for instance https://alice.solid.net
  2. Then login in the pod with your SOLID account, for instance https://bob.solid.net
  3. Thereafter you navigate into Alice folders, only if she granted you the necessary rights to access her POD.

This small detail shows that the current version is a prototype that still requires some improvement.


#6

Regarding the upload of pictures: I have tried the live-version, which is able to visualize my files and folders.

However, it does not work properly and always inform me that I didn’t made a correct login in my account when I try to set a new folder or upload a picture, despite I am already in my SOLID-Pod:

Error: SFCFetchError 401 https://lighorne.inrupt.net/public/P1270596.JPG - Make sure that the user is properly logged in

It seems to be that I must upload this code in order to manipulate my data in a much more comfortable way, and that the live option still don’t work.

Is there any other option to upload pictures?


#7

Not sure what you mean by being “in my SOLID-Pod” but just visiting a pod does not mean you are logged in. Solid-File-Manger and the libraries it is based on are known to work in many situations so I suggest you investigate further. If the problem turns out to be with the app, file an issue so that others may benefit from your experience. Did you look in the console logs of your browser? There should be much information there including warnings if you tried to login in and couldn’t. Maybe cut and paste those logs and we can see if we spot anything.


#8

This could also happen when you logging/logout with more than one webid as you did for the first problem.
Be sure you are not logged anymore, clean the cookies & localstorage, or better if you have , try with another webbrowser. When I need two webid for test, I login one in Firefox and the other in chrome.
Don’t remember if @jeffz solid-ide or pod-explorer can upload pics . https://scenaristeur.github.io/solidash/browser.html ( use the external tool link)


#9

And look at your ‘Preferences’ tab too to be sure that the app you want to use has ‘write acces’


#10

Solid File Manager, Solid-IDE, and Solid Shell, and now Data Kitchen can all upload images. But those all use Solid File Client. This seems like a login issue, rather than an upload issue. I second @Smag0’s suggestion to clear cache and cookies.


#11

You can also use the data browser and it’s drag and drop feature (drag your picture onto the plus). It works for me


#12

Thanks a lot for the assistance and tips. I can now upload pictures using the green plus symbol (to me it was not intuitive).

I have an additional question: how can folders or data be deleted? (I only see in the profile/card#me the option to delete pictures)


#13

All of the libraries and apps I mentioned above do deleting. If you want to delete in the dataBrowser, click on the gear-shaped “under-the-hood” element. For more details of using the dataBrowser, see the Data Browser Userguide.


#14

Great! It works. Thank you also for the link to the Userguide