Have you tried Spoggy with your POD+ ML?

Have you tried Spoggy with your POD ?

Just change the “source” parameter with the POD you want to browse :
Do you prefer the Public Folder ?
or the Profile ?
You can directly put a subfolder :
a json file :
or a ttl one :

If you want to use it on your phone, use the fullscreen mode !

Double-click on a node browse the folder if it’s a folder or show the content of the file as a graph.

Please give me feedback.


Great work! Thanks! After having taking another look, let me amend my comments: WOW! This is really amazing

Can’t wait to play with this. I love visualisation and interactive visual UI - spent years working on this kind of product and it is fascinating and fun.

Yes I want something ludique and fun so even my child or my grandma can share there ideas in RDF/turtle format.
Thxs , as you know nothing would be possible without your solid-file-client :wink:, and all advices found in this forum. Thxs everyone !

Another question : Has someone tried to plug any Machine Learning framework like ml5 (https://ml5js.org/ & https://ml5js.github.io/ml5-examples/p5js/Word2Vec/)
to his pod, something that could classify a public content, something that recognize patterns of relationship between nodes, that could learn that a Person has a name, for example ?

1 Like

I had a quick play and using the links in the ‘dashboard’ most of the ones under ‘Exemples JSON OK’ work, but I wasn’t able to import from my public folder.

I tried the dialog with ‘https://thewebalyst.solid.community/public/’ and also loading the URI https://scenaristeur.github.io/spoggy-simple/?source=https://thewebalyst.solid.community/public/ but both give an errror:

fetch errror TypeError: NetworkError when attempting to fetch resource.https://thewebalyst.solid.community/public/

… which from the console seems to be the usual CORS problem:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://thewebalyst.solid.community/public/. (Reason: CORS request did not succeed).

Anyway, I like the visualisation. One of the things I’m interested in is interacting with data through the visual UI. I see you have some ways to build the graphic.

Moving query and edit interactions directly into the GUI (drag and drop, click to edit in place, right click for actions and properties etc.) is a lot of work but transforms usability and productivity so wonder if anyone is thinking along those lines?

Strange, the URL Spoggy
Works for me

Was you logged in ?
For the interaction something could be possible with a right click that open a contextual popup

1 Like

I was using Firefox and it doesn’t matter if I’m logged in or not - same error. However, with Chromium it works, although the graphical area is a bit narrow (like your image).

Yes, right-click is useful for actions. We used to use it for queries (eg. ‘expand’ would reveal links around the clicked entity so you could explore data interactively). Also drag and drop of icons from a palette. Shift-drag to link from one entity to another. Entry of text for labels directly onto the chart etc. Double click to edit properties and so on.

@happybeing, as mentioned here https://github.com/scenaristeur/spoggy-simple/blob/master/README.md, I have tested with Firefox 66 but it was a long time, i’ll retest , what is yours?
The fetch is done by @jeffz solid-file-client, so @jeffz, have find some issue with Ff?

Firefox 67.0.1 64bit on Ubuntu 18.10

No one has reported FF issues to me, but I I’ll keep my eyes open.

@happybeing Do you have the same issue with other POD on Ff ?



For the moment, ‘expand’ interaction can be done
by double-click (or double-tap on touchscreen) on a node, and so until a file node, and when there are to much ‘navigation nodes’ , they can be collapsed in a red star with the ‘navigation button’ in the bottom middle, dble-click on the red star re-expand the navigation.

1 Like

Above the graphical area there is a purple link to pass the graphic in fullscreen

Yes, same error for all those.

Thanks. Interestingly, after I come back from fullscreen the graphic area is back to normal size.

this url works for me in FF 67.0.4

if I use “http” instead of “https” for the source, I got a (mixed content error) that is normal Spoggy

but I can’t reproduce, it definitely works for me.

The only way I found to get a CORS error is running the app in local without a webserver, opening the file:///C:/Users/Smag/Documents/dev/spoggy-simple/index.html?source=https://thewebalyst.solid.community/public from the filesystem like that :

If it’s from a local folder, you need nodejs ( > 10) and run “node index.js” in the root folder, then go to

But you test on the demo server https://scenaristeur.github.io/spoggy-simple ? right?
Did you try to clean your temporary files ?

Sorry for the delay…

Yes, using the link you posted I still get the same error, and I tried clearing the browser cache but it made no difference (with FF 67.0.1 (64-bit)).

It may be related to a plugin I suppose, but I don’t have time to got through them atm. Maybe see if anyone else has an issue, although I think most are still using Chrome (though I don’t understand why given the interest in privacy on this forum!).

For a first try, I added a “on-click menu” on nodes with two function “Edit” & “Expand” .

1 Like

Excellent! :smile:

If you want, I could try to plug Spoggy to a Solid-on-safe endpoint,:wink: is there an uri? An Api ? That I could try to get data ?

There’s no means for a web app to access SAFE from outside the network atm. You need to be running on SAFE or accessing it directly (via API in Browser or libraries). What I’m doing is providing versions of Solid libraries that make the app think it is talking to the Solid API but which go instead to the SAFE APIs.

The issue with Spoggy is that SAFE Browser has a problem with anything that uses jQuery (issue #903).

I got Solid IDE working yesterday, still in testing, so am making progress but I’m going to wait on Maifsafe over the jQuery issue. Once that is sorted out it should be fairly easy to get working, fingers crossed. Spoggy will make a great demo as well as being useful, so I’ll definitely come back to it.

Thanks for offering to help. :smile:

A cool feature of Solid IDE is that it has the Kitchen Sink feature. To pull up the menu simply scroll your mouse onto the editor, you will see the text curser go from solid to blinking, press command and the comma (,) keys and you will see the kitchen sink feature pop up. All kinds of goodies in there.