Getting Started - Error on any button click

Hi there!

First off, I’m completely new to solid. Hopefully this is not a too easy question.

I’m trying to run the Getting Started application, using PodSpaces. I can open the app locally, however, every button click returns an error.

As example, the “Login” button click returns this error:

Has anyone encountered this error as well?


I’ve just tried it by copy pasting all the snippets and for me it worked. Here is the code on github: GitHub - Otto-AA/solid-client-js-demo-app: Demo app copied from

You can run it with:

# download git repository
git clone
cd solid-client-js-demo-app/

# I didn't include the node_modules directory in git
# so you need to install the npm modules again with npm install
npm install

npm run build && npm run start

Does this work for you?

And I’m confused by your error messages, as I don’t have random script and css names (168726db…js and 9e386…css). Do you know where they come from?

I hope this helps!

1 Like

Thanks a lot! That worked perfectly fine.

I tried it again with the Tutorial to see where my mistake was, however, I couldn’t replicate it. Thanks again!

1 Like