Error: Web error: 413 (Request Entity Too Large) on PUT


I am trying to upload a audio to my pod (self-hosted). When I drag and drop it onto the green + symbol on “Your Storage” tab I get the below error. I do not have this error on a pod I own on another host provider.

Error: Web error: 413 (Request Entity Too Large) on PUT of

Any idea what can be the cause? I am using google chrome for my tests.

Thank you.

The 413 indicates that you are overquota. Your pod has reach storage limit permission.

My storeQuota I believe is big enough and I cannot even upload a 3MB audio sample.

It is under
solid:storageQuota “25000000000”

I think you must rename the file serverSide.ttl.inactive to serverSide.ttl

but apart from that you are right, I had the same quota-problem and only managed to upload a very small mp3 here

I have also another pod with solidcommunity and I have no problems uploading files there. On the solidcommunity pod I also have a serverSide.ttl.inactive.
I tried to move it to serverSide.ttl and has messed up my acl permissions on files …

@ewingson This is a webserver configuration problem, max_upload fields needs to be modified on apache or nginx.

@ch1ch0gz thanx, setting client_max_upload_size in nginx.conf fixed it.

for the acl-prob you can open an issue here

1 Like