Trouble with "Make A Solid App On Your Lunch Break"


#1

Tried the tutorial here:

https://solid.inrupt.com/docs/app-on-your-lunch-break

for my POD fdrouillard.inrupt.net.

I created a folder named “documents” within my public folder. Added these folders and html files:

  • index.html
  • popup.html
  • scripts
    — jquery.js
    — main.js
    — rdflib.min.js
    — solid-auth-client-bundle.js
    -styles
    — main.css

After step 5, things got wonky:
… "index.html " was renamed to “Profile Viewer”
… “popup.html” was renamed to “Select your Identiy Provider”

In a later step, I had trouble adding a file to “documents”:
… rdflib.min.js.map failed to upload (Payload To Large)

Tried deleting some items from my public folder but that didn’t help. I still get the error message:

Upload: FAIL https://fdrouillard.inrupt.net/public/documents/scripts//rdflib.min.js.map, Error: Error: Web error: 413 (Payload Too Large) on PUT of https://fdrouillard.inrupt.net/public/documents/scripts//rdflib.min.js.map.

I’ve uploaded larger image files, so I’m not sure why this error occurs.

It would be good to know if that tutorial is still valid.


#2

I think you are supposed to place those files on your own web-server - not in your POD. You are trying to build a web-app running in the browser and that needs a backing webserver to serve the files from. Maybe you can use your POD dataspace for it, but it sounds like asking for additional trouble.


#3

I had a similar idea, the users POD should also be like the home page too, why not deploy a custom web app there?

I did it in the root of the user’s container replacing the default index.html and copying other resources under public. It works nice, but I have one issue with the popup.html. It is a private resource and other users can’t access it for login. I haven’t found a way to chance the ACL from the popup under the root and placing it under public brings other problems, because the popup since to be designed to be beside the index.html.

I’d be thankful for any hints.

Bests.


#4

I would try the following :

  • remove index.html
  • at folder level allow ACL at file level
  • change ACL for popup.html
  • add back index.html

#5

Thanks a lot for your suggestions. I tried out, but it didn’t work either. Even setting write access for the root dir and the popup file, I get “403 Forbidden” response when trying to login. Maybe there is a special handling in the solid community server for the root container?

Anyway I could solve the issue for now by using the poopup from the community unter https://solid.community/common/popup.html

Cheers
Antonio.