Using POD server on Heroku

Sorry I am polluting the forum space with my questions.
But if there is somebody having knowledge of Heroku - please could you help me out?
Are there any technical problems to use PODs on Heroku given the Node.js server is
configured right?

1 Like

I don’t see any reason why it shouldn’t work, off the top of my head, but tagging @jaxoncreed or @michielbdejong who’ve worked on it and might know more.

1 Like

I successfully installed solid server via npm on the heroku web console - but failed to install certbot. I have tried exactly the way it is proposed in the solidorg documentation - but I dont have access to the /etc/apt/sources.list file,

I have tried using add-apt-repository too. But this command doesn’t seem to work.

Have you tried
‘brew install certbot’
as found here

Thanx for the proposal @Smag0 - but it didn’t work for me. I have stopped my efforts to get it running on Heroku - instead I focus on testing on localhost so I have full control of the operating system (Linux for sure) and so I don’t have to transfer my data with git.
I also need to have full control of my own MongoDB - and I think this is not supported on heroku with the free plans.
Later on when I have the money necessary, I will get me my own dedicated server.