Solid authorization and data handling without frontend?

Dear solid community,

About a month ago I made a post on the sunreddit asking for some advice for picking the right ontology for a university project.

In the meantime the choices regarding the ontlogy have been made and we were able to produce a static dataset in valid ttl syntax to verify we have all needed components.

This time I have a specific implementation question:
Is there a possibility to read and write files on a solid pod without having to run our code in the browser?
In the ideal case we’d want to run our code in a node.js server without a frontend whatsoever.

I decided to make this post because it seems like there are only two options available for solid authentication:

Which is profiled as being specifically a library to be used in browser development, and there following is stated specifically in the readme:

Note that this library is intended for the browser. You can use Node.js as a development environment, but not for actually logging in and out or making requests.

Furthermore there is:

But this library seems to have been deprecated 2 years ago and I suppose it’s better if we stay away from it.

Best regards,
Flor Sanders

Hi, did you take a look at @jeffz solid-auth-cli http://forum.solidproject.org/t/solid-auth-cli-browserless-persistent-login/ ?

1 Like

Just stumbled across it a couple of seconds ago ny reading some other post, more specifically:

Thanks for the answer! I think that solves the problem alltogether.

Flor

1 Like

I seem to be getting this error, does anyone know how to fix it?

This issue mentions adding scope ‘openid’ to solid-cli, but I don’t really have a clue as to how that should be done.
Any help would be greatly appreciated!

What OS are you using? How are you calling solid-cli?

I’m on windows 10, I’m attempting to use your solid-auth-cli tool in a nodejs environment.

I’m afraid I don’t have a windows box to test on. Make sure that you use the latest solid-auth-cli and have clean-installed all of its dependencies. Make sure that you don’t have any @trust or @solid libraries in a global place where they might be used instead. If you still get the problem, possibly try reverting to earlier versions of solid-cli and its dependencies in @trust. I hope to have time soon to look into this further, unfortunately that won’t be immediately. Please let me know of your progress or lack of it.

I had just clean installed everything (locally) but started fresh and repeated everything again, which gave me the same results.
I tried rolling back @solid/cli all the way through to 1.0.0 making sure to roll back @solid/oidc-rp as well to the version mentioned in the package.json file, but to no avail either.
Thanks for the suggestions already, if you have any more ideas on what I could try be sure to let me know.
I’ll try fooling around some more, might even install an ubuntu vm to see wether running it in a linux environment solves anything and I’ll be sure to let you know the results.

1 Like

With the help of CxRes’s pointers I was able to apply the quick fix of adding the ‘openid’ scope to the authenticate object and got it working. (See Github Issue mentioned previously).
If I could be of any more help to try and figure out a general fix, please let me know.
For the meantime I can get back to working on this project.
Thanks for the help!