How to add your picture to your Solid account?

To add a picture to your Solid profile:

  1. Go to your profile (In my case this is
  2. Drag the file with the picture you want and drop it onto the blank profile image.

Note: In my case, I added a second picture and then had to delete it. To see How to deleted a resource in your Solid account see: in the part Deleting a file.


Thank you for this explanation!

I also have two pictures of myself in my profile and want to delete one. I was able to find and delete the unwanted photo from my public profile resources, but it was also necessary to delete it from the Source code.

Few rubes like me, with your profile/card page showing, click the Source icon </>, then the pencil icon at the bottom right of the page, delete the unwanted photo from the code. I clicked the green check mark for good measure.

Back to one photo of me in my profile/card.


Thank you for adding this! I did the same to be honest, but decided that it was just me :slight_smile: and skipped adding the code thingy. I will now. And thanks for your feedback.

Are we able to upload a video or just a photo? and can you inform on how to put a link to another page in the notes. Thank you

1 Like

Hi! So far I have been able to upload a photo only. And also embed a video here: and soon will be writing about this.
As for the links, I have added links to my websites by clicking on my WebID - then scrolling down a bit and dragging links to the targets below. Plus, you can add a description in the notes and then hit Save note:


I am wondering how SOLID stores this image in the POD. Is the image converted into RDF format or POD supports .jpg formats?

1 Like

Uploading the image in the Solid POD, you get an URI for it. Also, there is an under the hood side, where you can describe your pic with RDF metadata if you decide to.

Hi, I succeeded in uploading a pic in my profile but it doesn’t show up when others enter my public profile…

1 Like

Hey there! I had the same issue. Maybe the setting of the pic do not allow that. Try changing the so called ACL setting of the file. Here is how to do that:

Thx for ur quick reply!
I guess there is just no codes for showing pic in the page of public profile coz I believe the access right of pic is for everyone to view. Here is my POD public folder link:

I made a pad for you to test whether you can see my pic (the simpson family photo):
For TheodoraPetkova to Test

1 Like

:slight_smile: Cool that you made this folder. I don’t see it :frowning:

Here’s the address of your profile pic - You can go there, hover over until you find the “rainbow” symbol - and edit the setting to public.

Sorry, my bad. I didn’t log out and test it…
I have already replaced my image link by that one I uploaded in public folder. I log out and check this time, and it works. It seems that a better way to do it is to upload a pic in public folder first, copy its link and paste the link in codes.

BTW, I didn’t find the rainbow button in the edit page…

If you check it now, it should work. Thx!

1 Like

Great! I see it now. Not sure why you cannot see the “rainbow” thing.

Hi, in fact, I have trouble to use that rainbow thing. I try to add some other users in an authenticated list to a file but fail to find out where to fill out.

Thx ahead!

1 Like

You need to drag the Globe onto the specific option and wait :slight_smile: