Unable to delete "big" files from inrupt.net Pod

Hello all!

For testing purposes I hosted a react-app in my solid-pod by uploading the build directory to it.
This worked ok, but now I wanted to delete the files.
I could delete everything except 2 files: https://harrystminrupt.inrupt.net/public/apps/website/

I have tried

  • web.inox.app
  • solid-filemanager
  • portal(.)inrupt(.)net

but all them throw an internal server error and are unable to delete the files.
I think this is because the files are too big, about 4+ MB.
I also tried deleting them using the node-libraries,
but with solid-node-client (which uses solid-client-authn-js) I can’t login to inrupt[.]net (invalid refresh credentials after getting them via getToken)
and with the older solid-file-client (which uses solid-auth-cli)
I get the same internal server error.

What other solutions are there? I think most of them use the same libraries for the deletion under the hood, so is there something wrong with them? How to fix them and make it possible to delete bigger files?

Thank you!

ps: Unfortunately I could only put 2 links

I don’t know of all of those which libraries they use, but the ones I know of use different libraries than Penny, so you could try deleting them using that:

(Give them a bit of time to load. You’ll need to sign in in the top right-hand corner to do so.)

That said, “Internal Server Error” makes it unlikely that the cause is the library - I’d expect it to be a problem with the server software. So if that doesn’t work, you could try reporting an issue there.

with solid-node-client (which uses solid-client-authn-js)

Only if you specify that as the handler, otherwise it uses solid-auth-fetcher by default.

I can’t login to inrupt[.]net (invalid refresh credentials after getting them via getToken)

Inrupt.com uses ESS and the getToken process. Inrupt.net uses NSS and does not yet have a valid getToken system though a PR has been submitted. Currently, the way to login to inrupt.net and NSS is with login sending username and password rather than a token and needs solid-auth-fetcher as the handler. See the solid-node-client README (get latest 2.x version of solid-node-client).

@jeffz
Thank you for the clarification! I tried it and it works now!
Unfortunately this doesn’t resolve the internal server error when trying to delete the files.

@Vincent
I haven’t seen Penny yet but it’s pretty cool.
Unfortunately it also throws an internal server error…
so I guess you are right and it’s a problem with the server software.
I will try and create an issue there, thanks!

Hi :wave: if you think they are too big, did you try to edit them in the data browser to make them empty, so you can delete it? Do you have more information about the internal error ? 500? Any complementary message ?

Could you grant me to owner https://spoggy-test9.solidcommunity.net/profile/card#me on the /website folder so I can try?

I also tried editing them but I’m not able to open the files for editing in the data browser or any of the mentioned solid-apps. (same error)
The console only says “Failed to load resource: the server responded with a status of 500 (Internal Server Error)” while the website sometimes displays “async-lock timed out”.

Sure, I added you!

BTW in the meantime I also opened an issue here: https://github.com/solid/node-solid-server/issues/1576

@Smag0 did you get to try resolving this? @hsteinmueller did you find a resolution? When this happened to me it seems the file was corrupted perhaps from a partial write: Deleting (or accessing) file hangs with 500 · Issue #55 · solid/solidcommunity.net · GitHub

sorry but no more success, even worst :frowning_face:

when i tried to put them empty, (i saw a message saying that your file did not have a contenttype) i added application/javascript for the .js and i thought they were replaced

but instead of replacing the file in the folder, it added the properties of the new file :thinking: :crazy_face:

so the folder had two ‘modified’, ‘size’… for the same file keeping the one from 2021-02-20 :face_with_raised_eyebrow:

when i wanted to delete, mine was deleted but not yours… staying at 2020-02-20…

I’ve tried with @Vincent Penny too
At some point i’ve felt with ‘FetchQueue errors’ could it be linked to @jeffz FetchQueue errors · Issue #461 · linkeddata/rdflib.js · GitHub

I said worse because now you got the folder at https://harrystminrupt.inrupt.net/public/apps/website/
and a file with same name but without trailing slash at https://harrystminrupt.inrupt.net/public/apps/website … Sorry, but i have no right to delete it.
And i think it make things a little more incoherent :roll_eyes: :grimacing:

Edit : 28/08/21

just deleted ldflex-query…js et ldflex-query…js.map using poPock https://scenaristeur.github.io/solid-vue-panes/editor

website is registered as container and file . this is a problem, i think

cannot delete blop.txt as PoPock seems no to be allowed

1 Like

Could you open an issue in NSS. I thought it was already resolved.