I would like to do some GraphQL-LD queries (with solid authentication) in different PODs with the help of the graphql-ld-comunica-solid lib.

Unfortunately it doesn’t work if the RDF file is in a solid POD of . At the opposite it’s OK with the example explained in graphql-ld-comunica-solid with source e.g:

Is there something I have missed with GraphQL-LD queries and solid POD ?

Thanks in advance for your help,


Just checking , they talk about this bug which (maybe?) looks like its still in NSS: , so you might want to see if you’re running into that.

Tagging @rubensworks, who wrote it IIRC.

Thanks for your quick answer. I have contacted Ruben about this. I’ll update this message as soon it’s solved.

I receive an http 401 when I do the query to my solid POD.
It seems to be inside ActorRdfDereferenceHttpParseBase.js (@comunica)
@rubensworks Is there something to configure in comunica for the authentication ?
solid.auth.login before the query is apparently not enough

Kind regards,


FYI I had an issue (401) because I tried to execute Graphql-ld-comunica-solid with nodejs. This lib is using and only works in browser environments, so undefined behaviour may occur when executing this in Node.js.

Inrupt has planned to work on solid-client-authn-node to help build server-side and console-based apps.

Once it will be done, Ruben will update Comunica to use that lib, so that things will work the same client-side and server-side