Problem with app deployment on GitHub Pages using inrupt generator


#1

Hi.

My teamates and I are creating a solid app called viade for our course Software Architecture and we are having a lot of trouble with the deployment. We saw a post on this forum from another team from our university (Solid App no able to find public resources in our repository) and since they had the same problem as us we followed the steps they did in order to solve their deployment but it did not work for us, we have been dealing with this problem for over a week now and we don´t find any solution, we are almost sure that it has something to do with the routing and that urls are not translated correctly. Here you have our repository https://github.com/Arquisoft/viade_en2a if you have any suggestion it would be highly valued.

Thanks.


#2

I have also tried github pages as an intermediate deployment for my app and gave up. But I know it’s because the React Router default is browserHistory and Github suggests using hashHistory. this article has a good description: https://www.pluralsight.com/guides/deploying-react-app-with-react-router-to-gh-pages


#3

Hi @Angelixus , the best way to get support on an Inrupt product is to file a ticket on our Service Desk here: https://inrupt.atlassian.net/servicedesk/customer/portal/1

Sounds like this would be a “Technical Support” ticket.


#4

PD: The application should be hosted on https://arquisoft.github.io/viade_en2a/ Moreover, the application seems not to be working also on local but it was working before trying to follow the aformentioned post so we think it all comes down to the same problem about the routing.


#5

@InruptKelly nice to see that Inrupt provide support for his products and that we can submit tickets… Could you please tell us a list of Inrupt’s product so we can know where to find support for those ? thxs


#6

Your homepage redirects to https://arquisoft.github.io/login which it definitely shouldn’t do. The other teams project uses the # for the routes (e.g. https://arquisoft.github.io/viade_en1a/#/login). I guess fixing this and doing what I suggested in the other forum thread would work (though I don’t know what exactly you need to do for that. You could ask the other team or check for differences between your repo and theirs). Good luck :))


#7

Not sure what atlassian.net is but it redirects to a .com
can you give us a little brief about what this site is, is it owned by Inrupt?
can we use our inrupt or solid.commuinity pod webid or do we need to get a
attlassian webid?


#8

Hi there Angelixus. I have done some investigation into this problem. I forked your repo (viade_en2a) into my github account and deployed to my own Github Pages. As expected, it did not initially work due to the routing problem.

Comparing your code to the code of the other team, I noticed there were some steps missing. In particular, the switch from BrowserRouter to HashRouter was not done. The work is small, but important as BrowserRouter will not work out of the box. During any change to the router, there will be some other changes needed as well, such as updating redirects and callbackUris. An example of this is on logout.

This information, with supplemental links and documentation, is available on the Create-React-App site as well, which explains the changes and why they are needed.

Once I followed the steps in the commits above and reviewed the HashRouter changes, I was able to get your app working on my own github pages deployment. There was still a little strangeness with the routing (in particular, it duplicated the project name in the route after the hash) but the routing was operational. It’s possible any other attempts at fixing the issue will need to be rolled back, I’m not sure what other steps you tried that may be hanging around still.


#9

Thank you so much!, We will try your fix.