How to change the Sharing settings for a resource?


#21

Ah :slight_smile: I was trying “inbox.acl” not “inbox/.acl”. Thanks.


#22

Can you help me again? I’ve got the ACL for /inbox/.acl:

@prefix : <#>.
@prefix n0: <http://www.w3.org/ns/auth/acl#>.
@prefix inbox: <./>.
@prefix c: </profile/card#>.

:ControlReadWrite
    n0:accessTo inbox:;
    n0:agent c:me, <mailto:jw@elfisk.dk>;
    n0:origin <http://elfisk.dk>;
    n0:defaultForNew inbox:;
    n0:mode n0:Control, n0:Read, n0:Write;
    a n0:Authorization.
:Read
    n0:accessTo inbox:;
    n0:defaultForNew inbox:;
    n0:mode n0:Read;
    a n0:Authorization.
:ReadWrite
    n0:accessTo inbox:;
    n0:defaultForNew inbox:;
    n0:mode n0:Read, n0:Write;
    a n0:Authorization.

I can see the agent “c:me” (my WebID) has Control, Read and Write access.

Now I want to grant access to the origin http://elfisk.dk which is the Origin header I can see in Fiddler. As you can see above I’ve tried n0:origin <http://elfisk.dk> - but without luck - the server returns “Not authorized”.

I have also tried n0:trustedOrigin <http://elfisk.dk> without luck.

The server has accepted my change: if I reload the .acl page I can se my changes.

If I try the exact same request, through Fiddler, without the “Origin” header, it returns 200-OK with the inbox data.

I’m trying to go through https://www.w3.org/wiki/WebAccessControl to understand what is going on. But apparently missing something.

Do you know what I am supposed to do?


My first app - adding resources?
#23

@JornWildt sorry for late response, I’ve been on away for a couple of days. I’m not quite into the whole access/resource sharing with apps yet, so I’ll refer to @timbl and @RubenVerborgh in hopes they might have time to answer your questions.

Just in case, have you looked at the Solid Specificatino and the parts on Authorization and Access Control?


#24

Yes, thanks, I’ve tried to understand both - it ends at https://github.com/solid/web-access-control-spec#referring-to-origins-ie-web-apps with “A specific ACL can be be made to allow a given app to access a given file or folder of files” … without further details about how its done plus some future ideas.


#25

.acl files.
How do you go directly to the file in the databrowser ?


#26

Sharing for file solidlinks.txt
Error reading ACL. status Can’t get headers to find ACL for <https://>: Failed to load <https://> Fetcher: fetch failed: TypeError: https:// is not a valid URL. status: 999: ( No ACL pointer https:// Can’t get headers to find ACL for <https://>: Failed to load <https://> Fetcher: fetch failed: TypeError: https:// is not a valid URL. status: 999)undefined
What I get when trying to change permissions as described in this post.


#27

This is only a problem with solid.tilde.team, not solid.community for some reason


#28

What’s you version of Solid ?


#29

If it’s on 5.0.0 beta you should report on chat node-solid-server. There is already a report on .meta files


#30

You can drag users by their webid straight into the rainbow access control panel above. One way to find a user to drag is to drag their icon/name from the author tab on a solid chat message. So chat with them and then add them.

Or you can follow a link to their webid, and then drag the URL bar icon .


#31

Thanks! I didn’t know that. I only knew I could drag WebId URLs into the FOAF panel. Will try the “custom” sharing. :]


#32

Another things you can drag into the window are Groups, from a group file or an address book. The group should have the webids of its members declared in that file.

In principal you can also drag in an Origin like https://tools.inrupt.net with NO TRAILING SLASH … but if you try to set that up in the browser (and other tools) They will tend to add a trailing slash, which mades it just a folder on the web.


#33

It worked. The first thing (the one with the Tools - I could’t get to anything)
I had hard time creating a group. Is it done only from the address book?
I had one, created some time ago - https://teodora.solid.community/public/testaddressbook/ and than managed to add a Group to it -
https://teodora.solid.community/public/testaddressbook/Group/wordsmiths.ttl#this. Then the dragging and the sharing with that group worked. [sharing some screenshots below + 1 error message] What is the text box above “Ne address Book - tools” and above “person name:” for?

When I add a contact is there a way this contact gets extracted (not sure about the word) from my “knows” file? Or from something like a Solid list of people :slight_smile: