Community-Server can't share a file to another webid

Hi all,
I used a pod in solidcommunity_dot_net for several months and worked fine. I’d like to try the new community-server 2.0.1 with signing up a pod from solidweb_dot_me these days.

I use the SolidOS Databrowser(in the README page) to login, create a folder, add a file and update the content of this file. But, I can’t share this file to my webid on solidcommunity_dot_net?
It returns “Error: ACL file save failed: Web error: 401 on PUT of test.ttl.acl” as shown below.
Do I do something wrong? or miss some critical setup?
Thank you for all your assistance!

I’ve come across this bug too but haven’t had a chance to debug it or report it yet.
It’s not clear whether it’s an issue with SolidOS or community server.

Compatibility of SolidOS with community server is still a work in progress since the new authentication was implemented, so I’d suggest using node solid server (e.g. solidcommunity.net) if you want a more mature experience.

The problem could be with the browser CORS and adding trusted applications
Adding https://solid.github.io as trusted app in the webId profile does not solve the problem.

I use https://penny.vincenttunru.com/ to edit the acl’s.

I use the penny app to edit the acl and it works.
I think it maybe a compatibility issue. I’ll still keep trying the community-server.
Thanks for helping.
By the way, there is no “http://www.w3.org/ns/auth/acl#trustedApp” option when I add a new property.

I appended “acl:origin https://solid.github.io/” to the “test.ttl.acl” file and tried again to add a share using DataBrowser.
Unluckly, I still got the same error message!